Update vulnerable Flash-Plugin for browser on mac os x

Sunday June 26th, 2016 | by PhilVanB | de_DE Dieser Artikel auf deutsch


This post explains how to get Flash running again when the error message "This plugin is vulnerable and should be updated." appears in the Firefox browser on your Mac OS X and Flash is being blocked. The approach described here basically works in other browsers (e.g. Safari) on your Mac-system as well.

Update vulnerable Flash-Plugin for browser

This message appears because your browser disables the Adobe Flash Player due to an old or vulnerable Flash-Version with security vulnerability.

Do the following in order to update Flash to the latest secure version and get it running again:

Download the latest Flash-version as a .dmg-File for your Mac OS X on the Adobe-Website: https://get.adobe.com/de/flashplayer/ .  The filename will be something like AdobeFlashPlayer_YOUR_VERSION_install.dmg

After the download change directories in the Finder on your Mac OS X and open up the downloaded file with a double mouse click. In the window opened click again with a double mouse on "Install Adobe Flash Player.app". Confirm to open in the following window. You might need to enter your username and password.
After that, go through the following steps in the Adobe Flash Player installation:

Update vulnerable Flash-Plugin for browser 1

 

Update vulnerable Flash-Plugin for browser 2

 

Update vulnerable Flash-Plugin for browser 3

Adobe has been downloaded and installed. Restart your Computer. Now Flash should work again without error message.



>